Skip to main content

The ACSC advises Google Chrome users to update their browser in order to patch a known vulnerability.

Google has released Chrome version 72.0.3626.121 for Mac, Windows and Linux. The update addresses a vulnerability which allows a remote attacker to take control of an affected system.

The ACSC recommends users apply the necessary updates to ensure their systems are best protected.

Further information

Further information about update can be found on the Google Chrome’s blog.

While no single mitigation strategy is guaranteed to prevent cyber security incidents, implementing the ACSC’s Essential Eight provides baseline protection.

To report a cyber-security incident or cybercrime, go to ReportCyber and report it.